icon

We found results for “

CVE-2016-9814

Good to know:

icon

Date: February 16, 2017

The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.

Language: PHP

Severity Score

Severity Score

Weakness Type (CWE)

Resource Management Errors

CWE-399

Top Fix

icon

Upgrade Version

Upgrade to version 1.14.10,1.9.1,1.10.3,2.3.3

Learn More

CVSS v3

Base Score:
Attack Vector (AV): NETWORK
Attack Complexity (AC): LOW
Privilegs Required (PR): NONE
User Interaction (UI): NONE
Scope (S): UNCHANGED
Confidentiality (C): NONE
Integrity (I): HIGH
Availability (A): HIGH

CVSS v2

Base Score:
Access Vector (AV): NETWORK
Access Complexity (AC): LOW
Authentication (AU): NONE
Confidentiality (C): NONE
Integrity (I): PARTIAL
Availability (A): COMPLETE
Additional information:

Do you need more information?

Contact Us