Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2025-13647
Published:November 02, 2026
Updated:November 04, 2026
The affected component fails to enforce expected validation constraints on the "content-type" header when processing certain requests. This allows an attacker to submit a crafted request with a manipulated "content-type" header. Successful exploitation can lead to the unintended exposure of the file paths for certificate files. This information disclosure could potentially be leveraged in subsequent attacks or compromise the confidentiality of the system.
Affected Packages
https://github.com/wso2/identity-api-server.git (GITHUB):
Affected version(s) >=v1.4.0 <v1.5.0
Fix Suggestion:
Update to version v1.5.0
https://github.com/wso2/identity-api-server.git (GITHUB):
Affected version(s) >=v1.0.44 <v1.3.219
Fix Suggestion:
Update to version v1.3.219
org.wso2.carbon.identity.server.api:org.wso2.carbon.identity.api.server.keystore.management.v1 (NEXUS):
Affected version(s) >=1.0.52 <1.3.219
Fix Suggestion:
Update to version 1.3.219
Do you need more information?
Contact Us
CVSS v4
Base Score:
6.9
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
NONE
User Interaction
NONE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
NONE
Vulnerable System Availability
NONE
Subsequent System Confidentiality
LOW
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
5.8
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
NONE
Scope
CHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Weakness Type (CWE)
Exposure of Sensitive Information to an Unauthorized Actor
EPSS
Base Score:
0.18