CVE-2026-100252
Published:November 04, 2026
Updated:November 04, 2026
Improper Authorization vulnerability in Apache ZooKeeper.
When SASL authentication is enabled on the client port, the server's SASL callback handler grants every authorization identity (authzid) that a client requests, without checking it against the principal the client authenticated as. The server then tries to replace the requested identity with a canonical form of the authenticated principal, derived from the zookeeper.security.auth_to_local rules. If no rule applies to the principal, canonicalization fails and the error is only logged. The client-requested authzid then becomes the session's SASL identity for all ACL checks.
An authenticated client whose principal is not covered by the auth_to_local rules can therefore claim any SASL identity. With the default rules, this includes any Kerberos principal from a realm other than the server's default realm, such as a principal from a cross-realm trusted realm. The client then gets the permissions granted to that identity in sasl ACLs. If the requested identity matches a configured zookeeper.superUser, it gets superuser access to the whole data tree.
Users are recommended to upgrade to version 3.8.8 or 3.9.7, which fixes the issue.
Affected Packages
https://github.com/apache/zookeeper.git (GITHUB):
Affected version(s) >=release-3.4.0-rc0 <release-3.8.8 || >=release-3.5.0-rc0 <release-3.8.8 || >=release-3.6.0 <release-3.8.8 || >=release-3.7.0 <release-3.8.8 || >=release-3.8.0-0 <release-3.8.8Fix Suggestion:
Update to version release-3.8.8https://github.com/apache/zookeeper.git (GITHUB):
Affected version(s) >=release-3.9.0 <release-3.9.7Fix Suggestion:
Update to version release-3.9.7org.apache.zookeeper:zookeeper (JAVA):
Affected version(s) >=3.9.0 <3.9.7Fix Suggestion:
Update to version 3.9.7org.apache.zookeeper:zookeeper (JAVA):
Affected version(s) >=3.5.0-alpha <3.8.8 || >=3.8.0 <3.8.8 || >=3.4.0 <3.8.8 || >=3.7.0 <3.8.8 || >=3.6.0 <3.8.8Fix Suggestion:
Update to version 3.8.8Related Resources (4)
Do you need more information?
Contact UsCVSS v4
Base Score:
8.6
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
LOW
User Interaction
NONE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
HIGH
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
8.1
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Weakness Type (CWE)
Incorrect Authorization