Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-107457
Published:November 02, 2026
Updated:November 04, 2026
A memory corruption vulnerability in the QMqttClient class of the Qt MQTT module. Under certain MQTT 5 connection settings between client and server, QMqttClient may corrupt memory, which can cause the application to crash.
Affected Packages
https://github.com/qt/qtmqtt.git (GITHUB):
Affected version(s) >=v6.12.0-beta1 <v6.12.0
Fix Suggestion:
Update to version v6.12.0
https://github.com/qt/qtmqtt.git (GITHUB):
Affected version(s) >=v5.12.0-alpha1 <v6.11.3 || >=v5.15.0-alpha1 <v6.11.3 || >=v6.0.0 <v6.11.3 || >=v6.2.0-alpha1 <v6.11.3 || >=v6.3.0-alpha1 <v6.11.3 || >=v6.5.0-beta1 <v6.11.3 || >=v6.6.0-beta1 <v6.11.3 || >=v6.8.0-beta1 <v6.11.3 || >=v6.9.0-beta1 <v6.11.3
Fix Suggestion:
Update to version v6.11.3
Do you need more information?
Contact Us
CVSS v4
Base Score:
2.3
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
PRESENT
Privileges Required
NONE
User Interaction
PASSIVE
Vulnerable System Confidentiality
NONE
Vulnerable System Integrity
NONE
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
Exploit Maturity
UNREPORTED
CVSS v3
Base Score:
6.5
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Weakness Type (CWE)
Improper Validation of Array Index
Out-of-bounds Write
EPSS
Base Score:
0.26