Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-109518
Published:November 04, 2026
Updated:November 05, 2026
On Debian, Ubuntu, and derivative Linux distributions, an on-path attacker who can manipulate the HTTP traffic (including a malicious mirror or proxy) between an APT client and an archive server triggered by a package install can trick the client into installing an attacker-controlled unverified package and achieve remote code execution with root privileges. The vulnerability is caused by the reuse of hard links and requires the client to follow redirects and retry the download of package files. It requires the client to have a non-zero Acquire::Retries configuration setting; the value 3 is the default starting with Debian 12 (bookworm) and Ubuntu 22.04 LTS (Jammy Jellyfish), so older releases are unaffected in a default configuration
Affected Packages
https://salsa.debian.org/apt-team/apt.git (SCM_GIT):
Affected version(s) >=1.5_alpha1 <1.6.19
Fix Suggestion:
Update to version 1.6.19
https://salsa.debian.org/apt-team/apt.git (SCM_GIT):
Affected version(s) >=1.7.0_alpha0 <1.8.2.4
Fix Suggestion:
Update to version 1.8.2.4
https://salsa.debian.org/apt-team/apt.git (SCM_GIT):
Affected version(s) >=3.1.0 <3.2.1
Fix Suggestion:
Update to version 3.2.1
https://salsa.debian.org/apt-team/apt.git (SCM_GIT):
Affected version(s) >=3.3.0 <3.3.6 || >=3.3.4 <3.3.6
Fix Suggestion:
Update to version 3.3.6
https://salsa.debian.org/apt-team/apt.git (SCM_GIT):
Affected version(s) >=2.1.0 <2.2.5
Fix Suggestion:
Update to version 2.2.5
https://salsa.debian.org/apt-team/apt.git (SCM_GIT):
Affected version(s) >=2.9.0 <3.0.4 || >=3.0.0 <3.0.4
Fix Suggestion:
Update to version 3.0.4
https://salsa.debian.org/apt-team/apt.git (SCM_GIT):
Affected version(s) >=1.8.3 <2.0.12 || >=2.0.0 <2.0.12
Fix Suggestion:
Update to version 2.0.12
https://salsa.debian.org/apt-team/apt.git (SCM_GIT):
Affected version(s) >=2.7.0 <2.8.4
Fix Suggestion:
Update to version 2.8.4
https://salsa.debian.org/apt-team/apt.git (SCM_GIT):
Affected version(s) >=2.3.0 <2.4.15
Fix Suggestion:
Update to version 2.4.15
https://salsa.debian.org/apt-team/apt.git (SCM_GIT):
Affected version(s) >=1.3_rc1 <1.4.12
Fix Suggestion:
Update to version 1.4.12
https://salsa.debian.org/apt-team/apt.git (SCM_GIT):
Affected version(s) >=0.7.21 <1.2.36 || >=1.0 <1.2.36
Fix Suggestion:
Update to version 1.2.36
https://salsa.debian.org/apt-team/apt.git (SCM_GIT):
Affected version(s) >=2.5.0 <2.6.2
Fix Suggestion:
Update to version 2.6.2
Do you need more information?
Contact Us
CVSS v4
Base Score:
7.7
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
PRESENT
Privileges Required
NONE
User Interaction
PASSIVE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
HIGH
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
8.8
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Weakness Type (CWE)
Time-of-check Time-of-use (TOCTOU) Race Condition
UNIX Hard Link