CVE-2026-111959
Published:November 02, 2026
Updated:November 04, 2026
Out-of-bounds read vulnerability in Apache Arrow Rust ("arrow" crate), from version 33.0.0 through to versions 57.3.1, 58.4.0, 59.3.1 and 60.0.0.
Improper validation of RunEndEncoded arrays in the ArrayData interface can allow reading data beyond the bounds of the child values array.
Users are recommended to upgrade to versions 60.1.0, 59.3.2, 58.4.1, 57.3.2 which fixes the issue.
Affected Packages
https://github.com/apache/arrow-rs.git (GITHUB):
Affected version(s) >=59.0.0 <59.3.2Fix Suggestion:
Update to version 59.3.2https://github.com/apache/arrow-rs.git (GITHUB):
Affected version(s) >=58.0.0 <58.4.1Fix Suggestion:
Update to version 58.4.1https://github.com/apache/arrow-rs.git (GITHUB):
Affected version(s) =32.0.0 <57.3.2 || =33.0.0 <57.3.2 || =34.0.0 <57.3.2 || =35.0.0 <57.3.2 || =36.0.0 <57.3.2 || =37.0.0 <57.3.2 || =38.0.0 <57.3.2 || =39.0.0 <57.3.2 || =40.0.0 <57.3.2 || =41.0.0 <57.3.2 || =42.0.0 <57.3.2 || =43.0.0 <57.3.2 || =44.0.0 <57.3.2 || =45.0.0 <57.3.2 || =46.0.0 <57.3.2 || =47.0.0 <57.3.2 || >=48.0.0 <57.3.2 || =49.0.0 <57.3.2 || =50.0.0 <57.3.2 || =51.0.0 <57.3.2 || >=52.0.0 <57.3.2 || >=53.0.0 <57.3.2 || >=54.0.0 <57.3.2 || >=55.0.0 <57.3.2 || >=56.0.0 <57.3.2 || >=57.0.0 <57.3.2Fix Suggestion:
Update to version 57.3.2https://github.com/apache/arrow-rs.git (GITHUB):
Affected version(s) =60.0.0 <60.1.0Fix Suggestion:
Update to version 60.1.0arrow-data (RUST):
Affected version(s) =41.0.0 <57.3.2 || =38.0.0 <57.3.2 || =44.0.0 <57.3.2 || >=53.0.0 <57.3.2 || =32.0.0 <57.3.2 || =34.0.0 <57.3.2 || =37.0.0 <57.3.2 || =35.0.0 <57.3.2 || =36.0.0 <57.3.2 || >=55.0.0 <57.3.2 || >=52.0.0 <57.3.2 || =33.0.0 <57.3.2 || =43.0.0 <57.3.2 || =39.0.0 <57.3.2 || =40.0.0 <57.3.2 || =42.0.0 <57.3.2 || >=48.0.0 <57.3.2 || =50.0.0 <57.3.2 || =45.0.0 <57.3.2 || =51.0.0 <57.3.2 || >=54.0.0 <57.3.2 || =49.0.0 <57.3.2 || =46.0.0 <57.3.2 || >=56.0.0 <57.3.2 || =47.0.0 <57.3.2 || >=57.0.0 <57.3.2Fix Suggestion:
Update to version 57.3.2arrow-data (RUST):
Affected version(s) >=59.0.0 <59.3.2Fix Suggestion:
Update to version 59.3.2arrow (RUST):
Affected version(s) =41.0.0 <57.3.2 || =38.0.0 <57.3.2 || =44.0.0 <57.3.2 || >=53.0.0 <57.3.2 || =32.0.0 <57.3.2 || =34.0.0 <57.3.2 || =37.0.0 <57.3.2 || =35.0.0 <57.3.2 || =36.0.0 <57.3.2 || >=55.0.0 <57.3.2 || >=52.0.0 <57.3.2 || =33.0.0 <57.3.2 || =43.0.0 <57.3.2 || =39.0.0 <57.3.2 || =40.0.0 <57.3.2 || =42.0.0 <57.3.2 || >=48.0.0 <57.3.2 || =50.0.0 <57.3.2 || =45.0.0 <57.3.2 || =51.0.0 <57.3.2 || >=54.0.0 <57.3.2 || =49.0.0 <57.3.2 || =46.0.0 <57.3.2 || >=56.0.0 <57.3.2 || =47.0.0 <57.3.2 || >=57.0.0 <57.3.2Fix Suggestion:
Update to version 57.3.2arrow-data (RUST):
Affected version(s) =60.0.0 <60.1.0Fix Suggestion:
Update to version 60.1.0arrow-data (RUST):
Affected version(s) >=58.0.0 <58.4.1Fix Suggestion:
Update to version 58.4.1arrow (RUST):
Affected version(s) >=58.0.0 <58.4.1Fix Suggestion:
Update to version 58.4.1arrow (RUST):
Affected version(s) >=59.0.0 <59.3.2Fix Suggestion:
Update to version 59.3.2arrow (RUST):
Affected version(s) =60.0.0 <60.1.0Fix Suggestion:
Update to version 60.1.0Related Resources (2)
Do you need more information?
Contact UsCVSS v4
Base Score:
8.8
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
NONE
User Interaction
NONE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
NONE
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
8.2
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
HIGH
EPSS
Base Score:
0.23