Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-11332
Published:June 05, 2026
Updated:November 04, 2026
A flaw was found in ansible-core. The ansible-galaxy role install command processes dependency specifications from a role's meta/requirements.yml file. Due to improper neutralization of argument delimiters, a malicious role author can inject arbitrary git configuration flags through the src field. This allows arbitrary code execution on the machine of a user who installs the role via ansible-galaxy role install.
Affected Packages
ansible-core (PYTHON):
Affected version(s) >=0.0.1a1 <2.16.19rc1
Fix Suggestion:
Update to version 2.16.19rc1
ansible-core (PYTHON):
Affected version(s) >=2.20.0b1 <2.20.7rc1
Fix Suggestion:
Update to version 2.20.7rc1
ansible-core (PYTHON):
Affected version(s) >=2.19.0b1 <2.19.11rc1
Fix Suggestion:
Update to version 2.19.11rc1
ansible-core (PYTHON):
Affected version(s) >=2.17.0b1 <2.18.18rc1
Fix Suggestion:
Update to version 2.18.18rc1
ansible-core (PYTHON):
Affected version(s) >=2.21.0b1 <2.21.1rc1
Fix Suggestion:
Update to version 2.21.1rc1
Related Resources (30)
Do you need more information?
Contact Us
CVSS v4
Base Score:
8.5
Attack Vector
LOCAL
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
NONE
User Interaction
PASSIVE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
HIGH
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
7.8
Attack Vector
LOCAL
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Weakness Type (CWE)
Improper Neutralization of Argument Delimiters in a Command
EPSS
Base Score:
0.22