CVE-2026-116204
Published:October 25, 2026
Updated:November 04, 2026
YesWiki before 4.7.0 contains a cross-site request forgery vulnerability in the despam action (tools/security/actions/despam.php) that lets unauthenticated attackers delete or restore pages through an administrator's session. Attackers can plant an auto-submitting raw HTML form on a wiki page, so an administrator who views it posts clean, suppr[], or rev[] parameters that delete PagePrincipale, configuration pages, or overwrite current content.
Affected Packages
https://github.com/YesWiki/yeswiki.git (GITHUB):
Affected version(s) >=v4.1.0 <v4.7.0Fix Suggestion:
Update to version v4.7.0https://github.com/YesWiki/yeswiki.git (GITHUB):
Affected version(s) >=v5.0.0-alpha1 <v5.0.0-alpha4Fix Suggestion:
Update to version v5.0.0-alpha4yeswiki/yeswiki (PHP):
Affected version(s) >=v5.0.0-alpha1 <v5.0.0-alpha4Fix Suggestion:
Update to version v5.0.0-alpha4yeswiki/yeswiki (PHP):
Affected version(s) =4.2.3 <v4.7.0 || >=v4.1.0 <v4.7.0Fix Suggestion:
Update to version v4.7.0Related Resources (4)
Do you need more information?
Contact UsCVSS v4
Base Score:
7.2
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
NONE
User Interaction
PASSIVE
Vulnerable System Confidentiality
NONE
Vulnerable System Integrity
HIGH
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
8.1
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
NONE
Integrity
HIGH
Availability
HIGH
Weakness Type (CWE)
Cross-Site Request Forgery
EPSS
Base Score:
0.14