Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-117613
Published:October 28, 2026
Updated:November 04, 2026
Jenkins 2.587 and earlier, LTS 2.580.1 and earlier does not restrict item types in collections after deserialization, allowing attackers with access to POST config.xml API endpoints to submit crafted "config.xml" files that can lead to, e.g., stored cross-site scripting (XSS) vulnerabilities.
Affected Packages
https://github.com/jenkinsci/jenkins.git (GITHUB):
Affected version(s) >=jenkins-2.580.1-rc <jenkins-2.580.2
Fix Suggestion:
Update to version jenkins-2.580.2
https://github.com/jenkinsci/jenkins.git (GITHUB):
Affected version(s) >=jenkins-2.581 <jenkins-2.588
Fix Suggestion:
Update to version jenkins-2.588
org.jenkins-ci.main:jenkins-core (JAVA):
Affected version(s) >=2.581 <2.588
Fix Suggestion:
Update to version 2.588
org.jenkins-ci.main:jenkins-core (JAVA):
Affected version(s) >=2.580 <2.580.2
Fix Suggestion:
Update to version 2.580.2
Do you need more information?
Contact Us
CVSS v4
Base Score:
5.1
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
LOW
User Interaction
PASSIVE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
LOW
Vulnerable System Availability
NONE
Subsequent System Confidentiality
LOW
Subsequent System Integrity
LOW
Subsequent System Availability
NONE
CVSS v3
Base Score:
5.4
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Weakness Type (CWE)
Deserialization of Untrusted Data
EPSS
Base Score:
0.29