CVE-2026-117622
Published:October 28, 2026
Updated:November 04, 2026
Jenkins 2.587 and earlier, LTS 2.580.1 and earlier allows agents to send exceptions implementing the Stapler HttpResponse interface to the controller, resulting in a cross-site scripting (XSS) vulnerability exploitable by attackers in control of agent processes.
Affected Packages
https://github.com/jenkinsci/jenkins.git (GITHUB):
Affected version(s) >=jenkins-2.581 <jenkins-2.588Fix Suggestion:
Update to version jenkins-2.588https://github.com/jenkinsci/jenkins.git (GITHUB):
Affected version(s) >=jenkins-2.580.1-rc <jenkins-2.580.2Fix Suggestion:
Update to version jenkins-2.580.2org.jenkins-ci.main:jenkins-core (JAVA):
Affected version(s) >=2.580 <2.580.2Fix Suggestion:
Update to version 2.580.2org.jenkins-ci.main:jenkins-core (JAVA):
Affected version(s) >=2.581 <2.588Fix Suggestion:
Update to version 2.588Related Resources (1)
Do you need more information?
Contact UsCVSS v4
Base Score:
5.3
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
NONE
User Interaction
PASSIVE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
LOW
Vulnerable System Availability
NONE
Subsequent System Confidentiality
LOW
Subsequent System Integrity
LOW
Subsequent System Availability
NONE
CVSS v3
Base Score:
6.1
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Weakness Type (CWE)
Improper Neutralization of Input During Web Page Generation
EPSS
Base Score:
0.29