CVE-2026-118514
Published:November 04, 2026
Updated:November 04, 2026
"Symfony\Component\HttpFoundation\RequestMatcher", and "RequestMatcher\MethodRequestMatcher" which replaces it from 6.2 on, match a request against a list of HTTP methods. They compared the request method to the list verbatim, while the router serves a "HEAD" request with the "GET" handler, as HTTP semantics require. Anything restricted to "GET" through such a matcher therefore did not apply to the same URL requested with "HEAD". The reachable consequence is "security.access_control", whose rules SecurityBundle compiles into these matchers, and firewalls, whose "methods" option is compiled the same way: The response carries no body, but its headers leak, and the controller executes with any side effect it has. A firewall restricted with "methods: [GET]" has the same gap: a "HEAD" request falls through to the next firewall matching the path, or to none. An application that builds a request matcher itself, for a custom firewall "request_matcher" or for any other method-restricted decision, is affected the same way. The fix for CVE-2026-45075 addressed the same gap in the "#[IsGranted]", "#[IsSignatureValid]" and "#[IsCsrfTokenValid]" attributes only.
Affected Packages
https://github.com/symfony/symfony.git (GITHUB):
Affected version(s) >=v6.0.0-BETA1 <v6.4.50Fix Suggestion:
Update to version v6.4.50https://github.com/symfony/symfony.git (GITHUB):
Affected version(s) >=v7.0.0-BETA1 <v7.4.23Fix Suggestion:
Update to version v7.4.23https://github.com/symfony/symfony.git (GITHUB):
Affected version(s) >=v8.0.0-BETA1 <v8.1.11Fix Suggestion:
Update to version v8.1.11https://github.com/symfony/symfony.git (GITHUB):
Affected version(s) >=v2.0.0BETA1 <v5.4.56 || >=v3.0.0-BETA1 <v5.4.56 || >=v4.0.0-BETA1 <v5.4.56 || >=v5.0.0-BETA1 <v5.4.56Fix Suggestion:
Update to version v5.4.56symfony/http-foundation (PHP):
Affected version(s) >=v7.0.0-BETA1 <v7.4.23Fix Suggestion:
Update to version v7.4.23symfony/http-foundation (PHP):
Affected version(s) >=v8.0.0-BETA1 <v8.1.11Fix Suggestion:
Update to version v8.1.11symfony/symfony (PHP):
Affected version(s) >=v8.0.0-BETA1 <v8.1.11Fix Suggestion:
Update to version v8.1.11symfony/http-foundation (PHP):
Affected version(s) >=v6.0.0-BETA1 <v6.4.50Fix Suggestion:
Update to version v6.4.50symfony/symfony (PHP):
Affected version(s) >=v7.0.0-BETA1 <v7.4.23Fix Suggestion:
Update to version v7.4.23symfony/symfony (PHP):
Affected version(s) >=2.0.4 <v5.4.56 || >=v2.0.9 <v5.4.56 || >=v4.0.0-BETA1 <v5.4.56 || >=v5.0.0-BETA1 <v5.4.56 || >=v3.0.0-BETA1 <v5.4.56Fix Suggestion:
Update to version v5.4.56symfony/http-foundation (PHP):
Affected version(s) >=2.0.4 <v5.4.56 || >=v4.0.0-BETA1 <v5.4.56 || >=v2.0.9 <v5.4.56 || >=v5.0.0-BETA1 <v5.4.56 || >=v3.0.0-BETA1 <v5.4.56Fix Suggestion:
Update to version v5.4.56symfony/symfony (PHP):
Affected version(s) >=v6.0.0-BETA1 <v6.4.50Fix Suggestion:
Update to version v6.4.50Related Resources (3)
Do you need more information?
Contact UsCVSS v4
Base Score:
6.3
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
PRESENT
Privileges Required
NONE
User Interaction
NONE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
LOW
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
6.5
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Weakness Type (CWE)
Incorrect Authorization