Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-119718
Published:October 30, 2026
Updated:November 04, 2026
Blender before 4.5.15 and 5.x before 5.2.3 contains a heap buffer overflow vulnerability caused by integer overflow in ptcache_data_alloc() when reading point cache files. Attackers can supply a crafted point cache file with a large totpoint value alongside a .blend file to crash Blender or execute code as the user.
Affected Packages
https://github.com/blender/blender.git (GITHUB):
Affected version(s) >=v5.0.0 <v5.2.3
Fix Suggestion:
Update to version v5.2.3
https://github.com/blender/blender.git (GITHUB):
Affected version(s) >=v2.50 <v4.5.15 || >=2.72b <v4.5.15 || >=v3.0.0 <v4.5.15 || >=v4.0.0 <v4.5.15
Fix Suggestion:
Update to version v4.5.15
bpy (PYTHON):
Affected version(s) >=4.2.0 <4.5.15
Fix Suggestion:
Update to version 4.5.15
bpy (PYTHON):
Affected version(s) >=5.0.0 <5.2.3
Fix Suggestion:
Update to version 5.2.3
Do you need more information?
Contact Us
CVSS v4
Base Score:
8.5
Attack Vector
LOCAL
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
NONE
User Interaction
PASSIVE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
HIGH
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
7.8
Attack Vector
LOCAL
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Weakness Type (CWE)
Integer Overflow or Wraparound
EPSS
Base Score:
0.19