Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-121413
Published:November 03, 2026
Updated:November 04, 2026
Parse Server before 8.6.112 and 9.0.0 before 9.10.6-alpha.4 contains an authorization bypass in the session upgrade endpoint, which creates a new session for any valid session token without enforcing the _Session class create class-level permission. Attackers holding a user's session token can send an already revocable token to /upgradeToRevocableSession to obtain additional sessions with fresh expiration that persist after the original session is logged out.
Affected Packages
https://github.com/parse-community/parse-server.git (GITHUB):
Affected version(s) >=9.0.0-alpha.1 <9.10.6 || >=9.0.0 <9.10.6 || >=9.10.6-alpha.1 <9.10.6
Fix Suggestion:
Update to version 9.10.6
https://github.com/parse-community/parse-server.git (GITHUB):
Affected version(s) >=2.2.19 <8.6.112 || >=3.0.0 <8.6.112 || >=4.0.2 <8.6.112 || >=5.0.0-alpha.1 <8.6.112 || >=5.0.0 <8.6.112 || >=6.0.0-alpha.1 <8.6.112 || >=6.0.0 <8.6.112 || >=7.0.0-alpha.1 <8.6.112 || >=7.0.0 <8.6.112 || >=8.0.0-alpha.1 <8.6.112 || >=8.0.0 <8.6.112
Fix Suggestion:
Update to version 8.6.112
parse-server (NPM):
Affected version(s) >=9.0.0-alpha.1 <9.10.6 || >=9.10.6-alpha.1 <9.10.6 || >=9.0.0 <9.10.6
Fix Suggestion:
Update to version 9.10.6
parse-server (NPM):
Affected version(s) >=4.0.2 <8.6.112 || >=2.2.19 <8.6.112 || >=7.0.0 <8.6.112 || >=3.0.0 <8.6.112 || >=6.0.0-alpha.1 <8.6.112 || >=8.0.0 <8.6.112 || >=5.0.0-alpha.1 <8.6.112 || >=6.0.0 <8.6.112 || >=7.0.0-alpha.1 <8.6.112 || >=8.0.0-alpha.1 <8.6.112 || >=5.0.0 <8.6.112
Fix Suggestion:
Update to version 8.6.112
Do you need more information?
Contact Us
CVSS v4
Base Score:
2.3
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
PRESENT
Privileges Required
LOW
User Interaction
NONE
Vulnerable System Confidentiality
NONE
Vulnerable System Integrity
LOW
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
3.1
Attack Vector
NETWORK
Attack Complexity
HIGH
Privileges Required
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
NONE
Weakness Type (CWE)
Incorrect Authorization
EPSS
Base Score:
0.31