Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-121441
Published:November 03, 2026
Updated:November 04, 2026
Wasmtime before 36.0.19, 37.0.0 before 48.0.7, and 49.0.0 before 49.0.4 contains a request smuggling vulnerability in wasi-http that allows guests to set multiple conflicting content-length headers. Malicious guests can make the host send HTTP requests with conflicting content-length values to smuggle requests through servers or intermediaries that do not reject them.
Affected Packages
https://github.com/bytecodealliance/wasmtime.git (GITHUB):
Affected version(s) >=v37.0.0 <v48.0.7 || >=v38.0.1 <v48.0.7 || >=v39.0.0 <v48.0.7 || >=v40.0.0 <v48.0.7 || >=v41.0.0 <v48.0.7 || >=v42.0.0 <v48.0.7 || >=v43.0.0 <v48.0.7 || >=v44.0.0 <v48.0.7 || >=v45.0.0 <v48.0.7 || >=v46.0.0 <v48.0.7 || >=v47.0.0 <v48.0.7 || >=v48.0.0 <v48.0.7
Fix Suggestion:
Update to version v48.0.7
https://github.com/bytecodealliance/wasmtime.git (GITHUB):
Affected version(s) >=v49.0.0-rc.1 <v49.0.4
Fix Suggestion:
Update to version v49.0.4
https://github.com/bytecodealliance/wasmtime.git (GITHUB):
Affected version(s) >=v9.0.0 <v36.0.19 || >=v10.0.0 <v36.0.19 || >=v11.0.0 <v36.0.19 || >=v12.0.0 <v36.0.19 || >=v13.0.0 <v36.0.19 || >=v14.0.0 <v36.0.19 || >=v15.0.0 <v36.0.19 || =v16.0.0 <v36.0.19 || >=v17.0.0 <v36.0.19 || >=v18.0.0 <v36.0.19 || >=v19.0.0 <v36.0.19 || >=v20.0.0 <v36.0.19 || >=v21.0.0 <v36.0.19 || >=v22.0.0 <v36.0.19 || >=v23.0.0 <v36.0.19 || >=v24.0.0 <v36.0.19 || >=v25.0.0 <v36.0.19 || >=v26.0.0 <v36.0.19 || =v27.0.0 <v36.0.19 || >=v28.0.0 <v36.0.19 || >=v29.0.0 <v36.0.19 || >=v30.0.0 <v36.0.19 || =v31.0.0 <v36.0.19 || >=v32.0.0 <v36.0.19 || >=v33.0.0 <v36.0.19 || >=v34.0.0 <v36.0.19 || =v35.0.0 <v36.0.19 || >=v36.0.0 <v36.0.19
Fix Suggestion:
Update to version v36.0.19
https://github.com/bytecodealliance/wasmtime.git (GITHUB):
Affected version(s) =v50.0.0-rc.1 <v50.0.0
Fix Suggestion:
Update to version v50.0.0
wasmtime-wasi-http (RUST):
Affected version(s) =50.0.0-rc.1 <50.0.0
Fix Suggestion:
Update to version 50.0.0
wasmtime-wasi-http (RUST):
Affected version(s) >=46.0.0 <48.0.7 || >=43.0.0 <48.0.7 || >=40.0.0 <48.0.7 || >=38.0.0 <48.0.7 || >=44.0.0 <48.0.7 || >=45.0.0 <48.0.7 || >=47.0.0 <48.0.7 || >=39.0.0 <48.0.7 || >=42.0.0 <48.0.7 || >=37.0.0 <48.0.7 || >=48.0.0 <48.0.7 || >=41.0.0 <48.0.7
Fix Suggestion:
Update to version 48.0.7
wasmtime-wasi-http (RUST):
Affected version(s) >=26.0.0 <36.0.19 || >=29.0.0 <36.0.19 || >=20.0.0 <36.0.19 || >=23.0.0 <36.0.19 || >=36.0.0 <36.0.19 || >=10.0.0 <36.0.19 || >=32.0.0 <36.0.19 || >=25.0.0 <36.0.19 || =16.0.0 <36.0.19 || >=13.0.0 <36.0.19 || >=17.0.0 <36.0.19 || =35.0.0 <36.0.19 || >=9.0.0 <36.0.19 || >=19.0.0 <36.0.19 || >=18.0.0 <36.0.19 || >=15.0.0 <36.0.19 || >=21.0.0 <36.0.19 || >=34.0.0 <36.0.19 || >=12.0.0 <36.0.19 || >=22.0.0 <36.0.19 || =31.0.0 <36.0.19 || >=33.0.0 <36.0.19 || >=11.0.0 <36.0.19 || >=14.0.0 <36.0.19 || >=24.0.0 <36.0.19 || =27.0.0 <36.0.19 || >=28.0.0 <36.0.19 || >=30.0.0 <36.0.19
Fix Suggestion:
Update to version 36.0.19
wasmtime-wasi-http (RUST):
Affected version(s) >=49.0.0-rc.1 <49.0.4
Fix Suggestion:
Update to version 49.0.4
Do you need more information?
Contact Us
CVSS v4
Base Score:
6.3
Attack Vector
NETWORK
Attack Complexity
HIGH
Attack Requirements
PRESENT
Privileges Required
NONE
User Interaction
NONE
Vulnerable System Confidentiality
NONE
Vulnerable System Integrity
LOW
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
3.7
Attack Vector
NETWORK
Attack Complexity
HIGH
Privileges Required
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
NONE
Weakness Type (CWE)
Inconsistent Interpretation of HTTP Requests
EPSS
Base Score:
0.22