Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-57193
Published:October 26, 2026
Updated:November 04, 2026
Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, the LDAP realtime driver "res_config_ldap" may permit "LDAP filter injection" through a "SIP username", allowing an unauthenticated attacker to make arbitrary LDAP queries using carefully crafted SIP packets and disclose information. The "res_config_ldap" module must be loaded and configured to access an LDAP server, which is not the default. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.
Affected Packages
https://github.com/asterisk/asterisk.git (GITHUB):
Affected version(s) >=22.0.0-rc1 <22.10.1
Fix Suggestion:
Update to version 22.10.1
https://github.com/asterisk/asterisk.git (GITHUB):
Affected version(s) >=certified-18.9-cert4 <certified-20.7-cert11 || >=certified-20.7-cert1-rc1 <certified-20.7-cert11
Fix Suggestion:
Update to version certified-20.7-cert11
https://github.com/asterisk/asterisk.git (GITHUB):
Affected version(s) >=certified-22.8-cert1-rc1 <certified-22.8-cert3
Fix Suggestion:
Update to version certified-22.8-cert3
https://github.com/asterisk/asterisk.git (GITHUB):
Affected version(s) >=21.0.0-rc1 <21.12.3
Fix Suggestion:
Update to version 21.12.3
https://github.com/asterisk/asterisk.git (GITHUB):
Affected version(s) >=23.0.0-rc1 <23.4.1
Fix Suggestion:
Update to version 23.4.1
https://github.com/asterisk/asterisk.git (GITHUB):
Affected version(s) >=1.6.0-beta2 <20.20.1 || >=10.0.0-beta1 <20.20.1 || >=11.0.0-beta1 <20.20.1 || >=12.0.0-alpha1 <20.20.1 || >=13.0.0-beta1 <20.20.1 || >=14.0.0-beta1 <20.20.1 || >=15.0.0-beta1 <20.20.1 || >=16.0.0-rc1 <20.20.1 || >=17.0.0-rc1 <20.20.1 || >=18.0.0-rc1 <20.20.1 || >=19.0.0-rc1 <20.20.1 || >=20.0.0-rc1 <20.20.1
Fix Suggestion:
Update to version 20.20.1
Do you need more information?
Contact Us
CVSS v4
Base Score:
6.9
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
NONE
User Interaction
NONE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
NONE
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
5.3
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Weakness Type (CWE)
Improper Neutralization of Special Elements in Data Query Logic
EPSS
Base Score:
1.96