CVE-2026-57196
Published:October 26, 2026
Updated:November 04, 2026
Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an unauthenticated attacker may use reflected cross-site scripting in "phone provisioning HTTP error pages" to retrieve an authorized user's "AMI session cookie" and impersonate that user when "res_phoneprov" is enabled. The Asterisk HTTP web server, Asterisk Manager Interface (AMI), and AMI access via HTTP must all be enabled; each is disabled by default. The attacker must be able to connect to the HTTP server, which binds only to "127.0.0.1" by default even when enabled, and must convince the authorized user to click a malicious link. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.
Affected Packages
https://github.com/asterisk/asterisk.git (GITHUB):
Affected version(s) >=certified-18.9-cert4 <certified-20.7-cert11 || >=certified-20.7-cert1-rc1 <certified-20.7-cert11Fix Suggestion:
Update to version certified-20.7-cert11https://github.com/asterisk/asterisk.git (GITHUB):
Affected version(s) >=22.0.0-rc1 <22.10.1Fix Suggestion:
Update to version 22.10.1https://github.com/asterisk/asterisk.git (GITHUB):
Affected version(s) >=21.0.0-rc1 <21.12.3Fix Suggestion:
Update to version 21.12.3https://github.com/asterisk/asterisk.git (GITHUB):
Affected version(s) >=certified-22.8-cert1-rc1 <certified-22.8-cert3Fix Suggestion:
Update to version certified-22.8-cert3https://github.com/asterisk/asterisk.git (GITHUB):
Affected version(s) >=23.0.0-rc1 <23.4.1Fix Suggestion:
Update to version 23.4.1https://github.com/asterisk/asterisk.git (GITHUB):
Affected version(s) >=12.7.0-rc1 <20.20.1 || >=13.0.0-beta3 <20.20.1 || >=14.0.0-beta1 <20.20.1 || >=15.0.0-beta1 <20.20.1 || >=16.0.0-rc1 <20.20.1 || >=17.0.0-rc1 <20.20.1 || >=18.0.0-rc1 <20.20.1 || >=19.0.0-rc1 <20.20.1 || >=20.0.0-rc1 <20.20.1Fix Suggestion:
Update to version 20.20.1Related Resources (17)
Do you need more information?
Contact UsCVSS v4
Base Score:
2.3
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
PRESENT
Privileges Required
NONE
User Interaction
PASSIVE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
LOW
Vulnerable System Availability
LOW
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
6.3
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
LOW
Weakness Type (CWE)
Improper Neutralization of Input During Web Page Generation
EPSS
Base Score:
0.77