CVE-2026-7514
Published:September 16, 2026
Updated:November 04, 2026
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 13.9 before 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 that an authenticated user with developer-role permissions could substitute package file content and hide packages from their owners due to improper authorization checks in the Generic Package Registry.
Affected Packages
https://github.com/gitlabhq/gitlabhq.git (GITHUB):
Affected version(s) >=v13.9.0-rc41 <v19.1.8 || >=v14.0.0-rc42 <v19.1.8 || >=v15.0.0-rc42 <v19.1.8 || >=v16.0.0-rc42 <v19.1.8 || >=v17.0.0-rc42 <v19.1.8 || >=v18.0.0-rc42 <v19.1.8 || >=v19.0.0-rc42 <v19.1.8Fix Suggestion:
Update to version v19.1.8https://github.com/gitlabhq/gitlabhq.git (GITHUB):
Affected version(s) >=v19.3.0-rc42 <v19.3.2Fix Suggestion:
Update to version v19.3.2https://github.com/gitlabhq/gitlabhq.git (GITHUB):
Affected version(s) >=v19.2.0-rc42 <v19.2.6Fix Suggestion:
Update to version v19.2.6Related Resources (6)
Do you need more information?
Contact UsCVSS v4
Base Score:
5.3
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
LOW
User Interaction
NONE
Vulnerable System Confidentiality
NONE
Vulnerable System Integrity
LOW
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
4.3
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
NONE
Weakness Type (CWE)
Missing Authorization
EPSS
Base Score:
0.38