Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-78252
Published:September 16, 2026
Updated:November 04, 2026
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 15.3 before 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 that, under certain conditions, an authenticated user could have induced a targeted user to perform unintended state-changing HTTP requests due to improper sanitization of user-controlled data in the Markdown JSON table renderer.
Affected Packages
https://github.com/gitlabhq/gitlabhq.git (GITHUB):
Affected version(s) >=v15.3.0-rc42 <v19.1.8 || >=v16.0.0-rc42 <v19.1.8 || >=v17.0.0-rc42 <v19.1.8 || >=v18.0.0-rc42 <v19.1.8 || >=v19.0.0-rc42 <v19.1.8
Fix Suggestion:
Update to version v19.1.8
https://github.com/gitlabhq/gitlabhq.git (GITHUB):
Affected version(s) >=v19.3.0-rc42 <v19.3.2
Fix Suggestion:
Update to version v19.3.2
https://github.com/gitlabhq/gitlabhq.git (GITHUB):
Affected version(s) >=v19.2.0-rc42 <v19.2.6
Fix Suggestion:
Update to version v19.2.6
Do you need more information?
Contact Us
CVSS v4
Base Score:
8.9
Attack Vector
NETWORK
Attack Complexity
HIGH
Attack Requirements
NONE
Privileges Required
NONE
User Interaction
PASSIVE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
HIGH
Vulnerable System Availability
LOW
Subsequent System Confidentiality
HIGH
Subsequent System Integrity
HIGH
Subsequent System Availability
LOW
CVSS v3
Base Score:
8.2
Attack Vector
NETWORK
Attack Complexity
HIGH
Privileges Required
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
LOW
Weakness Type (CWE)
Improper Neutralization of Input During Web Page Generation
EPSS
Base Score:
0.27