Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
WS-2026-0178
Published:November 04, 2026
Updated:November 04, 2026
Active Storage before 8.0.5.2 and 8.1.x before 8.1.4.1 names the tempfile it hands to ffprobe, ffmpeg and ImageMagick with the uploaded filename's extension, letting an attacker choose the decoder, which can disclose files or lead to RCE via AviSynth (GHSA-v924-7rp8-4mxh).
Affected Packages
https://github.com/rails/rails.git (GITHUB):
Affected version(s) >=v6.0.0.rc1 <v8.0.5.2 || >=v6.1.0.rc1 <v8.0.5.2 || >=v7.0.0.alpha1 <v8.0.5.2 || >=v7.1.0.beta1 <v8.0.5.2 || >=v7.2.0.beta1 <v8.0.5.2 || >=v8.0.0.beta1 <v8.0.5.2
Fix Suggestion:
Update to version v8.0.5.2
https://github.com/rails/rails.git (GITHUB):
Affected version(s) >=v8.1.0.beta1 <v8.1.4.1
Fix Suggestion:
Update to version v8.1.4.1
activestorage (RUBY):
Affected version(s) >=8.1.0.beta1 <8.1.4.1
Fix Suggestion:
Update to version 8.1.4.1
activestorage (RUBY):
Affected version(s) >=6.1.0.rc1 <8.0.5.2 || >=6.0.0.beta1 <8.0.5.2 || >=5.2.0.rc1 <8.0.5.2 || >=7.1.0.beta1 <8.0.5.2 || >=8.0.0.beta1 <8.0.5.2 || >=7.0.0.alpha1 <8.0.5.2 || >=7.2.0.beta1 <8.0.5.2
Fix Suggestion:
Update to version 8.0.5.2
Do you need more information?
Contact Us
CVSS v4
Base Score:
8.7
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
LOW
User Interaction
NONE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
HIGH
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
8.8
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Weakness Type (CWE)
Reliance on File Name or Extension of Externally-Supplied File