icon

We found results for “

CVE-2021-25916

Date: March 16, 2021

Overview

Prototype pollution vulnerability in 'patchmerge' versions 1.0.0 through 1.0.1 allows an attacker to cause a denial of service and may lead to remote code execution.

Details

The NPM module `patchmerge` can be abused by Prototype Pollution vulnerability since the module did not check for the type of object before assigning value to the property. Due to this flaw an attacker could create a non-existent property or be able to manipulate the property which leads to Denial of Service or potentially Remote code execution.

PoC Details

The module accepts two arguments `original, patch`. Due to the absence of validation, at values passed into `patch` arguments, an attacker can supply a malicious value by adjusting the `patch` value to include the `__proto__` property. Since there is no validation before assigning property to check whether the assigned `patch` is the Object's own property or not, the property `isAdmin` will be directly assigned to the empty obj({}) thereby polluting the Object prototype. Later in the code, if there is a check to validate `isAdmin` the value would be substituted as "true" as it had been polluted.

PoC Code

var patchMerge = require('patchmerge');
 var obj = {}
 console.log("Before : " + obj.isAdmin);
 patchMerge(obj, JSON.parse('{ "__proto__": { "isAdmin": true }}'));
 console.log("After : " + obj.isAdmin);

Affected Environments

1.0.0-1.0.1

Prevention

Upgrade to 1.0.2

Language: JS

Good to know:

icon
icon
icon

Upgrade Version

Upgrade to version patchmerge - 1.0.2

Learn More

Base Score:
Attack Vector (AV): Network
Attack Complexity (AC): Low
Privilegs Required (PR): None
User Interaction (UI): None
Scope (S): Unchanged
Confidentiality (C): High
Integrity (I): High
Availability (A): High
Base Score:
Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): Partial
Availability (A): Partial
Additional information: